As per the vSphere 7.0 release notes the following CPU processors are no longer supported:

  • Intel Family 6, Model = 2C (Westmere-EP)
  • Intel Family 6, Model = 2F (Westmere-EX)

You can append the following ESXi boot option which will allow you to bypass the unsupported CPU during the installation/upgrade. To do so, just use SHIFT+O and append the following:

allowLegacyCPU=True

Note: This is not officially supported by VMware, this changes can be done for home lab use but not for production as there might be some issues that you might encounter with.